PDF-foutmelding Drupal Commerce: verschil tussen versies

Uit De Vliegende Brigade
Ga naar: navigatie, zoeken
(Aanvullende gegevens)
(Acties)
Regel 27: Regel 27:
 
* https://github.com/dompdf/dompdf/issues/902
 
* https://github.com/dompdf/dompdf/issues/902
 
* https://www.drupal.org/project/commerce_invoice/issues/2912777
 
* https://www.drupal.org/project/commerce_invoice/issues/2912777
 +
 +
=== PHP-log bekijken ===
  
 
== Mogelijke oorzaken ==
 
== Mogelijke oorzaken ==

Versie van 13 sep 2019 om 12:15

In sep. 2019 kon een klant geen PDF-documenten van bestellingen genereren.

Acties

Log file

Binnen Drupal: Administration » Reports » Recent log messages:

TYPE	        php
DATE	        Friday, September 13, 2019 - 10:55
USER	        Jeroen Strompf
LOCATION	https://example.com/admin/commerce/orders/45634/pdf-invoice?destination=admin/commerce/orders
REFERRER	https://example.com/admin/commerce/orders
MESSAGE	        Dompdf\Exception: No block-level parent found. Not good. in Dompdf\Positioner\Inline->position() 
                (line 48 of /var/www/example.com/sites/all/libraries/dompdf/src/Positioner/Inline.php).
SEVERITY	error
HOSTNAME	12.34.56.78
OPERATIONS	

Deze foutmelding gegoogled

Weinig directe hits, ook niet als ik "Drupal" toevoeg aan de foutmeldingstekst. Oa:

PHP-log bekijken

Mogelijke oorzaken

  • Te oude PHP-versie op de server?
  • Commerce Billy PDF die een bug bevat?
  • De server + alle sites waren een dag eerder geüpdate. Dat kan een rol spelen.

Aanvullende gegevens

  • PHP-versie op deze server: 5.6.40-12+ubuntu18.04.1+deb.sury.org+1
  • De fout treedt vermoedelijk op rondom module Commerce Billy Invoice
  • De server + alle sites waren een dag eerder geüpdate. Dat kan een rol spelen.