Upgrade MySQL

Uit De Vliegende Brigade
Ga naar: navigatie, zoeken

Het probleem

Op m'n werkstation heb ik MySQL 5.7.19-0ubuntu0.16.04.01. Op een server heb ik versie 5.5.57-0ubuntu0.14.04.1. Die discrepantie begint problematisch te worden bij migratie van databases. Deze server werk ik regelmatig bij middels sudo apt-get update && sudo apt-get upgrade, maar da's blijkbaar niet genoeg.

Aanvullende gegevens

Geïnstalleerd via apt-get

Zo ver ik kan nagaan, heb ik MySQL toendertijd geïnstalleerd middels

sudo apt-get install mysql-server
sudo mysql_secure_installation

Daarom verbaast het me, dat ik het niet middels apt-get kan updaten zoals hierboven beschreven.

Lijst met geïnstalleerde pakketten

MySQL komt ook voor in de lijst van geïnstalleerde pakketten:

ikke@hiero:~$ dpkg --get-selections | grep mysql
libdbd-mysql-perl				install
libmysqlclient18:amd64				install
mysql-client-5.5				install
mysql-client-core-5.5				install
mysql-common					install
mysql-server					install
mysql-server-5.5				install
mysql-server-core-5.5				install
php5-mysql					install

Oorzaak

Tjakka: Ubuntu 5.5 is de standaarversie voor deze versie van Ubuntu! Daarom word-ie niet bijgewerkt. Dat kan uiteraard wel. Zie [1] voor details.

Oplossing

Archiveren

Eerst alle databases backuppen (4,7GB, 5 minuten):

mysqldump --lock-all-tables --all-databases > migratie_dump.sql

Daarna via controlepaneel een snapshot gemaakt van de server.

Bronnen