Rules-update-storing (Drupal, begin 2019)

Uit De Vliegende Brigade
Ga naar: navigatie, zoeken

Begin 2019 kreeg ik zowel op Drupal 6- als Drupal 7-webwinkels storingen na een update van de Rules-module.

Probleem

The website encountered an unexpected error: Begin 2019 kreeg ik deze foutmelding bij zowel Drupal 6- als Drupal 7-sites

Diagnose

Gewoon commando drush geven. Impressie (Drupal 7-site):

supervrouw@Server37:~$ example
supervrouw@Server37:/var/www/example.com$ drush
array_diff(): Argument #1 is not an array faces.inc:229                                                   [warning]
class_implements(): Class RulesPluginFeaturesIntegrationInterface does not exist and could not be loaded  [warning]
faces.inc:233
PHP Fatal error:  Unsupported operand types in /var/www/example.com/sites/default/modules/contrib/rules/includes/faces.inc on line 233
Drush command terminated abnormally due to an unrecoverable error.                                        [error]
Error: Unsupported operand types in
/var/www/example.com/sites/default/modules/contrib/rules/includes/faces.inc, line 233

Oplossing

Backup van Rules terugzetten. Impressie:

cd /var/www/example.com/sites/default/modules/contrib/rules
rm -rf *
cp -R ~/drush-backups/example.com/20190124184607/modules/rules/* .

Zie ook