Installatie Drupal Commerce 2.x - Algemeen

Uit De Vliegende Brigade
Ga naar: navigatie, zoeken

Zie ook

Requirements

Composer

Drupal Commerce (DC) moet je installeren mbv. het PHP versioning-systeem composer. Hier de installatiehandleiding.

PHP-libraries - Algemeen

Ik gebruik PHP 7.0. Versie 7.1 gaf een vage maar vooral weinig vertrouwenswekkende foutmelding. Vandaar dat ik versie 7.0 gebruik. Deze libraries heb je zoal nodig (lijst is niet compleet). Na installatie van een library, moet je waarschijnlijk de server herstarten: sudo service apache2 restart.

php-bcmath

sudo apt-get install php7.0-bcmath # PHP 7.0
# sudo apt-get install php-bcmath  # PHP 7.1

php-curl

sudo apt-get install php7.0-curl # PHP 7.0
# sudo apt-get install curl      # PHP 7.1

Na herstart van de server, deed-ie 't nog steeds niet. Wel na herstarten van de computer. Zie ook [1]

php-gd

sudo apt-get install php7.0-gd # PHP 7.0
# sudo apt-get install gd      # PHP 7.1

Bronnen

php curl-library

Drupal Commerce 2.x - Officiële documentatie