Installatie & bijwerken van Python

Uit De Vliegende Brigade
Ga naar: navigatie, zoeken

Casus: 3.5 → 3.7 (okt. 2019)

Op m'n laptop heb ik al twee versies van Python staan: 2.x en 3.x. Deze laatste wil ik nu upgraden. Dan schijn je issues met compatibilieit te kunnen krijgen, omdat Python nogal diep verweven is met het OS. Daarom zou je een nieuwe versie naast de bestaande versie moeten insalleren. Lijkt me ingewikkeld.

Poging 1

Blijkbaar kan dit niet via upgrade ofzo: Je moet Python opnieuw installeren. En ook dat gaat niet zomaar [1]:

sudo add-apt-repository ppa:jonathonf/python-3.7
sudo apt update
sudo apt-get install python3.7

De truuk is, da Python 3.7 naast Python 3.5 is geïnstalleerd, waarbij Python 3.5 de standaardversie is, ivm. compatibileit (?).

Dus python3 -V geeft als antwoord Python 3.5.2, maar python3.7 -V geeft als antwoord Python 3.7.4. Ik weet alleen niet of ik hier gelukkig van word.

Zie ook

Bronnen